How to solve the configure error: At least one of ncursesw/ncurses/pdcurses/curses library must be present

How to solve the configure error: At least one of ncursesw/ncurses/pdcurses/curses library must be present

When trying to run the ./configure file in a project that uses make, you will likely to find the following error:

error: At least one of ncursesw/ncurses/pdcurses/curses library must be present

Specifically if you don't have any of the mentioned libraries in your system. You can easily solve this problem installing the proper library. Depending of your environment the installation will be different.

Cygwin (Windows)

If you are in Windows using Cygwin, you will need to re-run the setup of Cygwin and include the following libraries:

  • libncurses++w10
  • libncurses-devel
  • ncurses

As shown in the following image, be sure to select the latest version:

NCurses Library

Then click on next and install the packages, this should solve the problem that you have with this dependency.

Debian/Ubuntu

If you are using a debian based distro, you may simply install the library with the following command using apt-get:

sudo apt-get install libncursesw5-dev

This should solve the problem in this environment.

RedHat/Fedora/CentOS

Alternatively if you are working on CentOS, install it using yum:

sudo yum install ncurses-devel

Happy coding ❤️!

This could interest you

Become a more social person